Troubles with NT45-O capsule

It’s been few days I have troubles with my newly purchased NT-45-O microphone capsules from Rode.


I recently bought 2 of them in an attempt to extend the possibilities with the NT5, and have them capture omnidirectionally.
While one of the capsule is working just great, the other one is doing its own concert of loud glitchy electronica.
I am assuming they don’t like the condition in Ecuador with too much humidity.
It is a bit frustrating as I have to set back from some recording setups I had planned.
I guess this is the price to pay for the difference in buying price compared to other manufacturer.

Rode NT5

I have to admit that during past recording trips, I also experienced some glitches with Rode. Although I found them to be not horrible and I was able to remove them at editing with pretty clean results.
But this time, the issue and the resulting noise is so predominent I won’t be able to use this track for its purpose. Maybe I can collect them for a glitch sound library 😉
I have to say the sound quality from Rode is usually really excellent and that is why I kept using Rode for many years. But if their behavior is unpredictable and they can’t stand a little humidity I have no choice other than removing them from my recording setup once and for all.

In comparison I had no problem with Sennheiser MKH under any conditions. Plus the weight make them much more suitable for field recording.

unfortunate surprise with the recorder

I got some unfortunate bad surprise when I powered on my Sound Devices 788t today. Neither the internal hard drive nor the compact Flash card was recognized.

After few seconds, a screen showed “updating Firewire/USB software”. This really strange behaviour prevent me from recording. I tried to restart the device many times.

After maybe ten attempts, it finally worked fine. I can’t explain why this happen. I contacted the technical support at Sound Devices, waiting now for some info.
I will keep update on this issue.